It's time to do something special!
# Table of Contents

1. Review .................................................................................................................. 1
2. Use Warning .......................................................................................................... 1
3. Firmware Prepare ................................................................................................. 1
   Step 1. download Arduino software ................................................................. 1
   Step 2. Use USB cable to connect Mega2560 and your PC ......................... 2
   Step 3. Download & Install U8glib library ..................................................... 2
   Step 4. Choose the board and port in Arduino IDE ..................................... 2
   Step 5. Download Ramps1.4 board Marlin firmware .................................. 2
   Step 6. Open Marlin Arduino File (Marlin.ino) in Arduino IDE .............. 2
4. Connection Installation Guide .............................................................................. 2
   4.1 RAMPS 1.4 Schematic ................................................................................. 2
   4.2 Insert jumpers to RAMPS 1.4 ................................................................. 4
   4.3 Install A4988 driver on Ramps 1.4 ............................................................ 4
   4.4 Install the RAMPS 1.4 on top of Mega2560 Boards ......................... 5
   4.5. Install the 12864LCD/2004LCD on Ramps 1.4 .................................. 5
   4.6 Connect power, Motors, Thermistors, Hotend, Heatbed, Fan ............. 6
      4.6.1 Connect Power .................................................................................. 7
      4.6.2. Connect Stepper Motor .................................................................. 7
      4.6.3 Connect thermistors ......................................................................... 8
      4.6.4 Connect Hotbed and extruder ......................................................... 9
      4.6.5 Endstop Connections ...................................................................... 9
5. More user guide online ...................................................................................... 10
FAQ ......................................................................................................................... 11
1. Review

This 3D printer kit consists of a RAMPS 1.4 shield, an Mega2560 board, a LCD screen, and a max of five Stepper drivers. RAMPS 1.4 is a popular control board for RepRap Prusa i3 3D compatible printer. It can control up to 5 stepper motors with 1/16 stepping precision and interface with a hotend, a heatbed, a fan (or a second hotend), a LCD controller, a 12V (or 24V with appropriate modification) power supply, up to three thermistors, and up to six end stoppers.

2. Use Warning:

1) Do not plug or unplug and wire or module when power is on,
2) Do not even touch the board when power is on or your hand has static charge (you can move static charge by touching metal tap).
3) Reversing +/- or otherwise incorrectly connecting power can destroy your electronics and cause fire hazard.
4) Incorrectly inserting stepper drivers will destroy your electronics and cause a fire risk. Always make sure power and USB is disconnected when removing or adjusting stepper drivers. Always make sure to insert drivers in correct orientation and in the socket correctly.
5) The endstop pins are Signal - GND - VCC, instead of the VCC - Sig - GND like the rest of RepRaps boards. Make sure to wire them correctly. This is done to allow squeezing fatter traces on the printable board.
6) DON’T secure Arduino/RAMPS with conductive screws through both mounting holes. The screw may cut into the positive trace creating a HIGH current short.
7) Test all electronics thoroughly before placing into service
8) Do not leave power supplied to electronics unattended, or run machines unattended due to the risk of fire and malfunction.
9) Once you start putting electricity into your RepRap - even at just 12 volts - you have to take basic, common sense precautions to avoid fires. Just in case these fail, test your workshop smoke detector.

3. Firmware Prepare (see page 10 to find more user guide online)

In the instructions, we recommend to install marlin firmware on the ramps. It’s appreciated that you enjoy other firmware installation experience in our official website.

Step 1. Download and install Arduino IDE software in your PC (The Arduino IDE version 1.5.X can upload the firmware stably):

https://www.arduino.cc/en/Main/OldSoftwareReleases#previous
Step 2. Use USB cable to connect Mega2560 and your PC. Your pc should detect Mega2560 and install driver automatically.

**Note:** If your pc can’t detect Mega2560 automatically, you can right click My Computer(in Win 10, right click This PC) -> Device Manager -> Ports (COM & LPT), right click the unknown device -> Update Driver software -> Browse my computer for driver software, then select Program Files (X86) -> Arduino Drivers, then OK and next. As soon as the driver is installed correctly, you will find the device "Arduino 2560" in your device manager. It will be visible 'Input (COM & LPT)'. The COM port will be distributed automatically.

Step 3. Download U8glib library from: [https://www.osoyoo.com/driver/U8glib.zip](https://www.osoyoo.com/driver/U8glib.zip) (If you have already installed U8glib, please skip this step).

Install U8glib library into Arduino IDE: Open Arduino IDE -> Sketch -> Include Library -> Add Zip Library -> select the zip file U8glib.

Step 4. Choose the board and port in Arduino IDE:

1) Open Arduino IDE -> Tools -> Board select Arduino Mega2560,
2) In Tools -> Port -> select the COM port which associated with Arduino Mega2560

Step 5. Download Ramps1.4 board Marlin firmware as per your LCD screen type. Unzip the file, you will see a folder called “Marlin”

We recommend marlin for the following two LCD screen:
Marlin for 12864 LCD: [https://www.osoyoo.com/driver/Marlin-ramps12864.rar](https://www.osoyoo.com/driver/Marlin-ramps12864.rar)

Step 6. In Arduino IDE->File->Open, find Marlin Folder and open Marlin Arduino File (Marlin.ino)

After the firmware is loaded into Arduino Mega2560 and connect all part properly, your LCD will show 3D printer menu.

4. Connection Installation Guide:

4.1 RAMPS 1.4 Schematic:
Reversing input power, and inserting stepper drivers incorrectly will destroy electronics.
4.2 Insert jumpers to RAMPS 1.4

The jumpers (in the plastic bag below) control the precision of the motor movement. To have the most precise stepping (1/16 micro stepping), insert three jumpers to each of the areas outlined below:

4.3 Install A4988 driver on Ramps 1.4

Make sure the orientation is correct as shown below! The potentiometer should be facing away from the “D10 D9 D8” side on the RAMPS 1.4 shield. We have heard numerous cases where these steppers got fried because of incorrect orientation. Install the heat sinks on the stepper drivers, and make sure the heat sink are not touching multiple components on the stepper driver (the clearance could be small, but it is there!)
4.4 Install the RAMPS 1.4 on top of Mega 2560 Boards:

The Mega 2560 board’s USB side is directly under RAMPS 1.4 shield’s “D8 D9 D10” area.

4.5. Install the 12864 LCD / 2004 LCD on Ramps 1.4
4.6 Connect power, Motors, Thermistors, Hotend, Heatbed, and Fan.
4.6.1 Connect Power

Connect your 12V power supply to the RAMPS shield. Reversing +/- or otherwise incorrectly connecting power can destroy your electronics and cause fire hazard. Get four spare wires and connect them on the two Com(V-) and the two V+ nodes. Connect the other ends to the RAMPS 1.4 shield’s power input nodes: (The first one on the bottom is COM(-V), then V+, then Com, then V+ again as shown below)

4.6.2. Connect Stepper Motor

The RAMPS board contains connectors for the X, Y, Z, E0, and E1 stepper motors. The Z connector is actually doubled so that you can plug 2 separate stepper motors into this one stepper driver. E0 and E1 are for your extruder stepper motors – if you have a single extruder on your machine, use E0.

**ATTENTION: Don’t use homing of the axis at this point!**

With homing the firmware moves all axis until it hits the endstop. If the stepper turns into the wrong direction the head or the bed will run into the wrong direction until it hits the mechanical end of the axis. You can only stop this by resetting the printer or turn of the power.
4.6.3 Connect thermistors

From left to right: Extruder 1 thermistor, heat bed thermistor, and extruder 2 thermistor. These are not polarity-sensitive. The thermistor leads need to be electrically isolated from each other — tiny Teflon tubing is best for this.
4.6.4 Connect Hotbed and Extruder

Plug in extruder 1 heater to D10, heatbed heater to D8, and fan (or a second extruder) to D9. Only the fan is polarity-sensitive.

4.6.5 Endstop Connections

From left to right of Ramps 1.4, each column corresponds to xmin, xmax, ymin, ymax, zmin, and zmax.

The mechanical endstoppers are polarity sensitive. Solder wires to the “COM” and “NC” leads. Connect these two leads to the top two rows in the endstopper area outline below, with COM on the bottom and NC on top. If you are using optical end stopper, then you will need all three pins.

In common usage, everyone just wires up an endstop to the minimum (zero point) for each axis, and then uses the software limits in the firmware to keep the printer from going too far in the opposite direction.
5. More user guide online

Additional information may be need, see the following URL for User Guide online

Firmware Installation Guide:  
http://osoyoo.com/2016/06/29/ramp1-4-board-for-reprap-3d-printer-firmware-installation-guide/

Connection graph Guide:  
http://osoyoo.com/2016/07/03/reprap-3d-printer-circuit-connection-graph/
FAQ

Q: What is the suggested input voltage? Or What type of power supply will I need?
A: The recommended power supply for Ramps is 12V, especially for Mega2560.
   If supplied over 12v, Mega will over heat, resulting in instability of operation, the
   serial port communication is was at times strong and at other times weak. Do
   make sure the power is 12v, if you don’t have switching power supply of 12v,
   please take down the diode D1 on Ramps if you use a greater power supply.
   The current is decided by the use of hotbed. If you use a hotbed, an idea power
   supply is 12v 17A, 200W. If not, 5A is enough.

Q: What’s requirement of the hotbed power?
A: The pair of connectors above marked 11A power a Heated Bed, or other output
   (D8). The source should be rated a minimum 11A. Please double check that you
   get positive to positive and negative to negative. Please keep the temperatures
   of heated bed less than 70 degrees Celsius to protect your power supply.

Q: What’s requirement of the extruder or hotend?
A: The bottom pair of connectors marked 5A power the stepper drivers and Extruder
   heater/fan (D9, D10). The source should be rated a minimum of 5A. the hot-end
   normally will reach up to 220-230 Celsius when melting ABS plastic.

Q: My PC can’t detect the mega2560 board?
A: You can right click My Computer(in Win 10, right click This PC) -> Device
   Manager -> Ports(COM & LPT), right click the unknown device -> Update
   Driver software -> Browse my computer for driver software, then select
   Program Files(X86) -> Arduino Drivers,then OK and next

Q: I can’t update the marlin firmware?
A: 1) Pls check Arduino IDE -> Tools -> Board select Arduino Mega2560
   2) In Tools -> Port -> select the COM port associated with Arduino Mega2560
   3) Please upload the marlin in different pc or use other USB cable

Q: What software is needed for this controller
A: You need Arduino Software go here to download:
   You can install Marlin Firmware onto the mega2560:
Q: Does this support two extruder? How about a heated bed?
A: It has two Extruder control points, as well as output for heated beds. It is a standard RAMPS 1.4.

Q: What are the amps set to on the stepper drivers? the motors I'm looking to control are 1.5A, so don't want to be putting 2A on them.
A: Vref = A*0.8, that means your motor are 1.5A, the stepper drivers amps are 0.8*1.5A.

Q: Why is my ramps1.4 board damaged?
A: 1) Do not plug or unplug and wire or module when power is on,
   2) Do not even touch the board when power is on or your hand has static charge (you can move static charge by touching metal tap).
   3) Always double check power wire is properly installed

Q: Can fan be added to Ramps?
A: Yes. If you use only one extruder, you can connect the fan to D9. If you use two extruders, you should connect fans to a power source, please attention that the fan is polarity-sensitive

Q: The temperature displaying on the screen is not properly.
A: 1) You may select the wrong thermistor in marlin.
   2) The thermistor is broken or there is short-circuit occurred in the 2 pins of the thermistor.
   3) The electrolytic capacitor on ramps is broken.

Q: When control the axis, but the motor doesn’t move, how to solve this?
A: 1) It is a matter of poor connection.
   2) A4988 has broke down.
   3) The VREF is not right.
   4) Please install jumpers under each stepper driver.
   5) Please make sure the connection of the motor correctly.

Q: The scope of motor is too small.
A: You may forget putting the jumper cap, or the parameter you set is wrong.
Q: The program uploading is not successful.
A: 1) The USB cable doesn’t work.
   2) The version of Arduino IDE you use is not compatible.
   3) The select of COM is wrong.

Q: The hotbed and extruder are not heated.
A: 1) The MOSFET is broken.
   2) The thermistor is not connected.

Q: The motor of extruder doesn’t work.
A: 1) The thermistor is not connected.
   2) The temperature is not hot enough.
   3) A4988 is broken.
   4) Ramps 1.4 is broken.

Q: Motors spinning in a different direction?
A: Please switch the power off and simply flip the motor connector. There are two connectors in parallel for Z axis, since most RepRap machines use two motors to move in Z direction.

Q: Why does the LCD show an ERR:MINITEMP?
A: Please make sure you connect the thermistor.
Products in this manual may be covered by US and International Patents. OSOYOO is a registered trademark of Pinetree Electronics Ltd. Any products names mentioned in this manual are the property of their respective parties.

Users are free to remix, tweak, and build upon this work for non-commercial use, as long as users credit Pinetree Electronics Ltd. and license their new creations under the identical terms.

©2017 Pinetree Electronics Ltd.

Every effort has been made to ensure that the information contained in this manual is accurate. Pinetree Electronics Ltd is not responsible for printing or clerical errors.

Pinetree Electronics Ltd.
9180 Wellmond Road
Richmond, BC V7E 1L5
Canada
www.osoyoo.com